Meerdere kwetsbaarheden verholpen in Samba
(NCSC-2018-0726)

medium Kans medium Schade

Beschrijving

Er zijn meerdere kwetsbaarheden verholpen in Samba. Hierdoor was het mogelijk voor een kwaadwillende om Denial-of-Service te veroorzaken, om beveiligingsmaatregelen te omzeilen of om toegang te verkrijgen tot gevoelige attributen. De meeste kwetsbaarheden zijn door een kwaadwillende op afstand te misbruiken. Het is niet bekend of de kwaadwillende geautoriseerd moet zijn om de kwetsbaarheden te misbruiken. Tevens is er een kwetsbaarheid verholpen waardoor het mogelijk was voor een malafide Samba-server om het geheugen van de Samba-client te overschrijven. Om deze kwetsbaarheid te misbruiken moet de kwaadwillende de gebruiker wel overtuigen om te connecten met een malafide Samba-server.

Mogelijke oplossingen

De ontwikkelaars van Samba hebben updates beschikbaar gesteld om de kwetsbaarheden te verhelpen. Voor meer informatie zie:
https://www.samba.org/samba/history/samba-4.8.4.html

Debian

Debian heeft updates van samba beschikbaar gesteld voor Debian 9.0 (Stretch) om de kwetsbaarheden met kenmerk CVE-2018-10858 en CVE-2018-10919
te verhelpen. U kunt de aangepaste packages installeren door gebruik te maken van 'apt-get update' en 'apt-get upgrade'. Meer informatie kunt u vinden op onderstaande pagina:
https://www.debian.org/security/2018/dsa-4271

Fedora

Fedora heeft updates voor Fedora 27 en 28 beschikbaar gesteld om de kwetsbaarheden in Samba te verhelpen. U kunt deze updates installeren met behulp van het commando 'dnf' of 'yum'. Meer informatie over deze updates en over een eventueel handmatige installatie vindt u op:
Fedora 27:
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/thread/7YJYQHQW2OGFNOT7P6SZ5G7A4EDHC2ND/
Fedora 28:
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/thread/JLO2ZIZN3LCSYBMKQC6WDL5AJYSE2UG2/

FreeBSD

FreeBSD heeft updates beschikbaar gesteld om de kwetsbaarheden te verhelpen in samba46, samba47 en samba48. U kunt deze updates installeren uit de FreeBSD ports. Meer informatie over deze updates vindt u op:
https://www.vuxml.org/freebsd/c4e9a427-9fc2-11e8-802a-000c29a1e3ec.html

OpenSUSE

De ontwikkelaars van OpenSUSE hebben updates beschikbaar gesteld om de kwetsbaarheden met kenmerk CVE-2018-10858 en CVE-2018-10919
te verhelpen in OpenSUSE Leap 42.3. Tevens zijn er updates beschikbaar gesteld voor OpenSUSE Leap 15 om alle kwetsbaarheden te verhelpen. U kunt deze aangepaste packages installeren door gebruik te maken van 'zypper'. U kunt ook gebruik maken van YAST of de updates handmatig downloaden van de OpenSUSE downloadserver (download.opensuse.org). Voor meer informatie, zie:
OpenSUSE Leap 42.3, CVE-2018-10858

https://lists.opensuse.org/opensuse-security-announce/2018-08/msg00056.html
OpenSUSE Leap 42.3, CVE-2018-10919

https://lists.opensuse.org/opensuse-security-announce/2018-10/msg00036.html
OpenSUSE Leap 15
https://lists.opensuse.org/opensuse-security-announce/2018-08/msg00059.html

Oracle

Oracle heeft updates beschikbaar gesteld voor Oracle Linux 7 om de kwetsbaarheden met kenmerk CVE-2018-1139 en CVE-2018-10858
te verhelpen. U kunt deze updates installeren met behulp van het commando 'yum'. Meer informatie over deze updates en over een eventueel handmatige installatie vindt u op:
https://linux.oracle.com/errata/ELSA-2018-3056.html

Red Hat

Red Hat heeft updates beschikbaar gesteld voor Red Hat Enterprise Linux 7 voor de kwetsbaarheden met kenmerken CVE-2018-1139 en CVE-2018-1085. U kunt deze updates installeren met behulp van het commando 'yum'. Meer informatie over deze updates en over een eventueel handmatige installatie vindt u op:
https://access.redhat.com/errata/RHSA-2018:3056

SUSE

SUSE heeft updates beschikbaar gesteld om de kwetsbaarheden te verhelpen in SUSE Linux Enterprise Server 12-SP3. U kunt deze aangepaste packages installeren door gebruik te maken van 'YaST'. U kunt de packages ook handmatig downloaden van de SUSE FTP-server (ftp.suse.com). Voor meer informatie, zie:
https://www.suse.com/nl-nl/support/update/announcement/2018/suse-su-20182319-1/

Ubuntu

Canonical heeft updates beschikbaar gesteld voor Ubuntu 14.04 LTS, 16.04 LTS en 18.04 LTS om de kwetsbaarheden met kenmerk CVE-2018-1139, CVE-2018-10858, CVE-2018-10918 en CVE-2018-10919
te verhelpen. U kunt de aangepaste packages installeren door gebruik te maken van 'apt-get update' en 'apt-get upgrade'. Meer informatie kunt u vinden op onderstaande pagina:
https://usn.ubuntu.com/3738-1/

Vrijwaringsverklaring

Door gebruik van deze security advisory gaat u akkoord met de navolgende voorwaarden. Ondanks dat het NCSC de grootst mogelijke zorg heeft betracht bij de samenstelling van dit beveiligingsadvies, kan het NCSC niet instaan voor de volledigheid, juistheid of (voortdurende) actualiteit van dit beveiligingsadvies. De informatie in dit beveiligingsadvies is uitsluitend bedoeld als algemene informatie voor professionele partijen. Aan de informatie in dit beveiligingsadvies kunnen geen rechten worden ontleend. Het NCSC en de Staat zijn niet aansprakelijk voor enige schade ten gevolge van het gebruik of de onmogelijkheid van het gebruik van dit beveiligingsadvies, waaronder begrepen schade ten gevolge van de onjuistheid of onvolledigheid van de informatie in dit beveiligingsadvies. Op dit beveiligingsadvies is Nederlands recht van toepassing. Alle geschillen in verband met en/of voortvloeiend uit dit beveiligingsadvies zullen worden voorgelegd aan de exclusief bevoegde rechter te Den Haag. Deze rechtskeuze geldt tevens voor de voorzieningenrechter in kort geding.

Trackback link

Nog geen reacties

Wees de eerste die reageert!

Laat een reactie achter

Je moet ingelogd zijn om te kunnen reageren.